Cisco router configuration

For Router No. 1

router> enable
router# configure terminal

Ethernet Port Config. (switch to router connection)
router(config)# interface f0/0
router(config-if)# ip address 192.168.16.1 255.255.255.192
router(config-if)# no shut
router(config-if)# exit

Serial Port Config. (router to router connection)
router(config)# interface s2/0
router(config-if)# ip address 192.168.16.129 255.255.255.192
router(config-if)# clock rate 56000
router(config-if)# exit

Routing Protocol Config.
router(config)# router eigrp 10
router(config)# network 192.168.16.1 255.255.255.192
router(config)# network 192.168.16.129 255.255.255.192
router(config)# exit
router# exit
router> exit


For Router No. 2

router> enable
router# configure terminal

Ethernet Port Config. (switch to router connection)
router(config)# interface f0/0
router(config-if)# ip address 192.168.16.65 255.255.255.192
router(config-if)# no shut
router(config-if)# exit

Serial Port Config. (router to router connection)
router(config)# interface s2/0
router(config-if)# ip address 192.168.16.130 255.255.255.192
router(config-if)# exit

Routing Protocol Config.
router(config)# router eigrp 10
router(config)# network 192.168.16.65 255.255.255.192
router(config)# network 192.168.16.130 255.255.255.192
router(config)# exit
router# exit
router> exit


PC configuration:

H-1: IP Address: 192.168.16.2        
        Subnet mask: 255.255.255.192
        Default Gateway Address: 192.168.16.1

H-2: IP Address: 192.168.16.3        
        Subnet mask: 255.255.255.192
        Default Gateway Address: 192.168.16.1

H-3: IP Address: 192.168.16.66      
        Subnet mask: 255.255.255.192
        Default Gateway Address: 192.168.16.65 

H-3: IP Address: 192.168.16.67      
        Subnet mask: 255.255.255.192
        Default Gateway Address: 192.168.16.65


      ……………………………………………………………………………………………..................

Some Basic Information:


IP Address: 192.168.16.15
Class: C
By Default Subnet Mask: /24
We need 3 network Addresses.

That’s why I have to divide the given ip address.
We need to borrow 2 bit from host part. (32-24)
So our subnet mask /26= /24+2

 



                   Network part                      Host part
11000000. 10101000. 00010000. 00001111
11111111. 11111111. 11111111. 11000000
………………………………………………
11000000. 10101000. 00010000. 00000000

192.168.16.0 /26  ………     N-1
192.168.16.64 /26  ………   N-2
192.168.16.128 /26  ……… N-3

192.168.16.192 /26  ……… N-4


Written by